月別アーカイブ: 2009年6月

楽譜を画像化してワードなどに貼り付ける2

前回保存した楽譜の一部をワードに貼り付けてみます。
ワードを起動したら、[挿入]メニューの[図]をポイントして、表示されたメニューの[ファイルから]をクリックしてください。
前回保存したファイルを選択すると、ワードのカーソル位置に画像(楽譜の一部)が挿入されます。
図(クリックすると拡大します)はScore Magazineとワードを表示したものです。
To_image

ワードではレイアウト例として、挿入した画像を右クリックすると表示されるミニメニューから[図の書式設定] → [レイアウト]タブ → [外周] → [左揃え]を順にクリックしています。
違う画像に差し替えたい場合は、画像をクリックしてパソコンキーボードの[Delete]キーで削除したあと、別の画像を挿入してください。
「切り取った楽譜の範囲がちょっと違ったかな…」などという場合は、前回の楽譜の画像化とこの挿入の作業を繰り返していただければいいと思います。

楽譜を画像化してワードなどに貼り付ける1

楽譜を人に紙で見せたい場合は印刷をしていただければいいですし、楽譜をScore Magazineを持っていない方のパソコンで見てもらいたい場合はScore Magazine Reader(演奏・印刷も可)をインストールしていただければいいと思います。
楽譜をワードやホームページなどに貼り付けたい場合は画像化する必要があります。
ページ単位で画像化するには、Score Magazineで[ファイル]メニューの[表示中のページを画像データで保存]を実行してください。
保存する際のファイルの種類ですが、写真などの画像が貼り付けてある楽譜はJPEGファイルで保存した方がいいと思いますし、画像がなければGIFファイルでも十分だと思います。
ビットマップファイルは画像を圧縮処理しないので劣化しない状態で保存することができますが、ファイルサイズがJPEGやGIFの数十倍になりますし、通常ホームページ用途には使用しません。
実際に画像にしてJPEGファイルと見比べられるといいかもしれません。
次に、楽譜の一部を画像化する場合です。
[設定]メニューの[ポインタを画像範囲選択ツールに]をクリックしてください。
ソフトを起動してファイルを開いたときは[ポインタを移動ツールに]にチェックが付いていますが、これで[ポインタを画像範囲選択ツールに]の方にチェックが付いた状態になります。
[表示]メニューの[倍率指定]で希望の表示サイズに変えて、ワードやホームページなどに貼り付けたい部分を範囲指定してください。
範囲指定はクリックしてドラッグすることで行います。
やりなおしたいときは楽譜上でクリックしてください。指定範囲が解除されます。
最後に、[ファイル]メニューの[選択範囲を画像データで保存]を実行してください。

Score Magazineでサムネイル的に楽譜を閲覧

Score MagazineはTrue Typeフォントを使って楽譜を表示していますので、楽譜の拡大・縮小が自在です。
[表示]メニューの[全体表示]をクリックすると1ページ全体が縮小表示されますので、MIDIファイルを楽譜として確認するだけならばNote EditorよりScore Magazineで開く方が便利です。
図(クリックすると拡大します)は[表示]メニューの[倍率指定]で「設定値」を「25」にしたものです。
Thumbnail

10トラック以上で2ページにわたるような大きな編成の曲でも、図の状態で演奏すれば全体を確認しながら聴くことができます。
スクロールバーを使ったり、「しおり」のページ番号をクリックしたあとキーボードの[↑][↓]キーを使ったりして、楽譜をサムネイル的に閲覧して行く使い方もできると思います。

五線部分が真っ黒になってしまう症状について

前回は、Note Editorの楽譜とScore magazineの楽譜の表示の違いをお話ししました。
Note Editorの楽譜は画像で表示していますが、Score Magazineの楽譜はTrue Typeフォントで表示しています。これは、ワードなどで選ぶことのできる文字フォントと同じものです。
True Typeフォントは、高速に表示するために一時的なファイル(キャッシュファイル)に格納されるのですが、ごくまれにこのキャッシュファイルが破損することがあります。
図(クリックすると拡大します)の上が正常な状態、下がキャッシュファイルが破損した状態です。
Cache

この症状はTrue Typeフォントを使用していないNote Editorでは発生しません。
これを改善するためには、「お読みください」の「五線部分が真っ黒になってしまうとき」に書かれているように、Score Magazineの新しいバージョンをインストールし、それでも改善しない場合はセーフモードで起動する、という手順をお試しください。

Note Editorの楽譜は編集重視、Score Magazineの楽譜は印刷イメージです

下図(クリックすると拡大します)は、Note Editorを起動した状態でTr.1にピアノ鍵盤中央「ド」より1オクターブ低い「ド」の4分音符を入力し、続けて[設定]メニューの[楽譜のレイアウト]で1ページの段数を12(1ページに12トラック表示されるよう)にしたものです。
P1tr12_ne

1ページに表示できる段数を初期値の8から12に増やしたため、入力可能な音程の範囲が狭くなっています。
それに伴い、入力済み4分音符の「たま」の位置はTr.2の入力範囲に重なるため、「たま」が見えなくなっています。
下図は同じ曲ファイルをScore Magazineで開いたものです。
P1tr12_sm

Note Editorでは見えなかった「たま」が表示されています。
さらに、Note Editorのプレーヤーにあったテンポの値「120」が、楽譜の左上に「テンポ=」で表示されています。
このように、Score Magazineを使えば、印刷前に印刷イメージを確認することができます。

楽譜ファイルを公開するときはフォントにご注意ください

Score Magazineをお持ちでない(コーラス部などの)メンバーの方に、Score Magazine Readerをダウンロードしてもらって、Note Editorで作った楽譜を配布する方も増えてきました。
Score Magazine ReaderはScore Magazineで作成した曲ファイルを閲覧・演奏・印刷することができるフリーソフトです。
Readerダウンロードのページへ
ご存知の方もいらっしゃると思いますが、AとB二つのパソコンがあったとして、Aにしかインストールされていない文字フォントを使用してワードなどで文章を書いたら、その文章ファイルをBで開いてもAと同じ文字フォントでは再現されません。
Note Editorでコードネームや歌詞のフォントを変更するときも同じように注意が必要です。
下図(クリックすると拡大します)は、Note Editorでコードネームや歌詞を「まるもじ」フォントで書いたものです。
Font_noteedi

下図は上の曲ファイルを、「まるもじ」フォントがインストールされていないパソコンのScore Magazine Readerで開いたものです。
Font_scoremag

そのパソコンにインストールされているフォントで代替表示されているのがわかると思います。
このような状況を避けるには、検索エンジンで「Windows 標準フォント」などと検索して、一般的なフォントをご使用になるといいと思います。

五線左端に「in ○」という表記があればNote Editor Proで作成した楽譜です

前回、Note Editor Proには移調楽器機能があるとお話ししました。
Note Editorで作成した曲ファイルはNote Editor Proで開くことができますが、その逆も可能です。
下図(クリックすると拡大します)は、Note Editor Proの移調楽器機能でTr.1にギターを設定(赤枠内のように「in C」と表記されます)したあと、続けてTr.2にピッコロを設定しようとしています。
Transpose1

ギターは実際の表記より1オクターブ低く演奏され、ピッコロは実際の表記より1オクターブ高く演奏される、どちらも移調楽器です。
下図は、移調楽器設定のあとに音符を入力した曲ファイルを、今度はNote Editorで開き、Tr.1とTr.2の音符をTr.3にコピーしたものです。
Transpose2

Tr.3は移調楽器設定がなされていないトラックですので、実際の表記と実際の演奏が一致したわけですね。
ちなみに、Tr.1もTr.2も「in C」としか書かれていないので、他の方に楽譜を見せることのあるNote Editor Proユーザーの方は、[設定]メニューの[各トラックの設定]で、[コメント]に「ギター」、「ピッコロ」などと入力した方が親切かもしれません。

トラックトランスポーズと移調・転調はどんなときに使う?

[編集]メニューの[トラックトランスポーズ]は、指定した一つのトラックの指定した範囲(音符単位)を半音単位で移動させます。
[編集]メニューの[移調・転調]は、その名のとおり、全トラックの指定した範囲(小節単位)をそのままの音程関係で別の調へ移動させます。
どちらも作曲や編曲のときに利用することが多いと思いますが、それ以外にもいくつか考えられます。
ギターやベースは実際の表記より1オクターブ低く演奏する移調楽器ですので、バンド譜などを見てそのままギターパートやベースパートを入力したあとに、トラックトランスポーズで全小節を「-12」にする(*)ことができます。
* Score Magazine Pro付属のNote Editor Proでは移調楽器機能で設定することもできます。
表記より1オクターブ高く演奏する記号「8va」や、逆に1オクターブ低く演奏する記号「8bassa」なども、バンド譜などを見てそのまま入力した場合は、その範囲に対してトラックトランスポーズを使ってください。
移調・転調の方は、ソングブックなどの曲を入力して演奏に合わせて歌ってみたら少しキーが高かった、というような場合に自分のキーに合わせることに利用できると思います。

Score MagazineのSMPファイルをNote Editorで編集する方法

前回までで、MIDIファイルとSMSファイルとSMPファイルの違いをイメージしていただけたのではないかと思います。
今回は、人からもらったSMPファイルに含まれている楽譜の音符などを編集したいときや、文章や画像を設定したあとに音符の間違いに気付いたときはどうすればいいのか、をお話ししたいと思います。
前者の場合ですが、編集したい楽譜をScore Magazineの画面に表示させて[ファイル]メニューの[表示中の曲をSMSファイルで保存]を実行してください。
いったんSMSファイルにすれば、そのファイルをNote Editorで開いて編集することができます。
後者の場合ですが、もし元のSMSファイルが存在しない場合は上の方法でSMSファイルを作成してください。
Note Editorで音符の間違いを修正してSMSファイルで保存したら、Score Magazineを起動して音符の間違いを含むSMPファイルを開き、音符の間違いのある楽譜を表示させます。
そして、[ファイル]メニューの[表示中の曲再読み込み]で修正済みのSMSファイルを開いてください。
設定した文章や画像はそのままに、表示中の楽譜が修正済みの楽譜(SMSファイル)に差し替えられます。

Score Magazineでの作業はNote Editorで曲が完成してから

今回は、Score Magazineで作成するSMPファイルについて簡単に説明させていただきたいと思います。
Score Magazineでは、まずMIDIファイルやNote Editorで作ったSMSファイルを読み込んで楽譜として表示します。
そして、その楽譜上に作詞・作曲者名や文章や画像を配置します。
図はその状態を表したものですが、その状態を保存したものがSMPファイルです。
Nedi_to_smag_2

作詞・作曲者名や文章や画像のデータはSMPファイルに属しており、Score MagazineはMIDIファイルやSMSファイルに直接変更を加えるわけではありません。
前々回でScore Magazineで作詞・作曲者名を入力しましたが、SMPファイルを作成する手順を考えると、このような作業はNote Editorで曲が完成したあとに行った方が効率的です。