admin のすべての投稿

『ミュースケ』がiPhone/iPadに対応

本日、iPhone/iPadに対応した『ミュースケ – Music Sketch Sheet』を公開(http://mappli.net/muske/)いたしました。
このバージョンより、Windowsでもそのまま音が出るようになり(*)、保存も可能になりましたので、より使いやすくなったと思います。
『Score Magazine』ともども、よろしくお願いいたします。
* HTML5のWeb Audio Apiという仕組みを使っています。

ソングブック(歌本)の入力方法解説

先日公開させていただきました無料楽譜スケッチアプリ「ミュースケ」ですが、ミュースケの使い方サイトで、ソングブック(歌本)の入力方法を掲載しています。
解説通りに進めると、音楽初心者の方でも、書店で販売しているソングブックの曲を簡単にミュースケに入力できると思います。
Score Magazineにも応用できると思いますので、ご参考にされてください。
http://mappli.net/muske-doc/songbook/

HTML5 無料楽譜スケッチアプリ『ミュースケ』公開

本日、Webブラウザ上で楽譜を簡単に作成・演奏できる『ミュースケ – Music Sketch Sheet』を公開(http://mappli.net/muske/)いたしました。
PCとブラウザさえあれば、どこでも無料でご利用いただける楽譜作成ソフトウェアです。
3パート4小節構成と非常にシンプルですが、4つまでの和音、ドラムトラック、128音色の楽器音(GM規格MIDI音源)など、多彩な演奏表現を楽しむことができます。
バンド練習中や音楽の授業中などに「ちょっと楽譜で音を確認したいな」というとき、お気軽にご利用いただければと思います。
『Score Magazine』ともども、よろしくお願いいたします。

移調楽器を演奏される方へ

(これはPro版の記事です)
Note Editor Proで移調楽器の設定をする際に、少し混乱されている方がいらっしゃるようですので、簡単に確認させていただきたいと思います。
アルトサックスを例に説明します。
ピアノのAに合わせてチューニングするとき、Eb管のアルトサックスは短三度高い音が出ますので、F#を吹いて合わせます。
これを音符にすると、ピアノの実音Aが下図(クリックすると拡大します)1、アルトサックスの記譜音F#が図2です。
Transpose_inst
もし仮に、ピアノの実音C(図3)に合わせるとすれば、アルトサックスは記譜音A(図4)になります。
この関係は、調の設定でも同じです。
[設定]メニューの[調・拍子・小節幅]で設定する調は実音です。
Note Editor Proに、アルトサックス用のA major(イ長調)の楽譜を入力するのであれば、[調・拍子・小節幅]にC major(ハ長調)を設定したあと、[設定]メニューの[移調楽器]で入力するトラックに「アルト・サクソフォーン in Eb」を設定してください。
同様に、アルトサックス用の楽譜がC major(ハ長調)ならば、[調・拍子・小節幅]にEb major(変ホ長調)を設定したあと、[移調楽器]で「アルト・サクソフォーン in Eb」を設定してください。
なお、[設定]メニューの[移調楽器]ダイアログボックスにある「曲の調号」とは、[設定]メニューの[調・拍子・小節幅]で設定されている調のことです。

パート譜とバンド譜の切り替え

前回お伝えしました「パートを非表示にする」方法を活用すると、簡単にパート譜とバンド譜の切り替えができます。
下図(クリックすると拡大します)aを見ると、Tr.1~Tr.4とTr.Drという5パート構成のバンド譜になっていますが、図bのように[表示]メニューの[トラック]で「Tr.1」以外のチェックを外せば、図cのようにTr.1だけのボーカルのパート譜になります。
Tr1_checked
* 5パートのバンド譜をレイアウトする手順はこちらをご覧ください。
この状態は、他のパートは非表示になっているだけなので、演奏すると(図には音符が入力されていませんが仮に入力されていたとして)全パートの音符が発音されます。
もし、ボーカルパートだけ発音させたいときは、[設定]メニューの[各トラックの設定]ダイアログボックスで、下図bの「トラック1」の「ソロ」にチェックを入れてください。
Set_track
逆に、ボーカルパートだけ発音させないで、他の全パートを発音させたいときは、図aの「トラック1」の「ミュート」にチェックを入れます。
こうすれば、ボーカルのパート譜を見ながら、カラオケで練習ができます。
パートの表示/非表示の活用
簡単にパートを表示/非表示にでき、非表示のパートも演奏できるという特徴は、いろいろな用途に活用できると思います。
パート数の多い楽譜で音符入力中、ページを送ったときに入力中のパートを探すのに手間取ることがありますが、音符入力中のパートをパート譜にすれば見渡しがよくなります。
リズム体のないパート構成の楽譜でも、リズムが取りやすいように軽いリズムの刻みが欲しい場合、Tr.Drを非表示にしてリズムを鳴らす、という使い方も考えられます。
トラックは簡単に非表示やミュートができるので、コーラスやベースのバリエーションを思い付くままにトラックを増やして試してみる、という使い方もできます。
みなさんも気軽に活用してみてください。

パート(トラック)数を変更するときのまとめ

Note Editor起動直後は、Tr.1~Tr.7とTr.Dr(ドラムトラック)という、8パート(八つの楽器を設定できる)構成になっています。
歌だけの楽譜やオーケストラスコアなど、作りたい楽譜によってパート構成は変わってきます。
不要なパートを非表示、または削除する
こちらの記事にも書きましたが、不要なパートを見えなくする方法は2種類あります。
削除せずに非表示にする方法と、削除する方法です。
非表示にするには、[表示]メニューの[トラック]で不要なTr.のチェックを外します。
削除するには、[編集]メニューの[トラックの削除]で不要なトラックを削除します。
ただし、Tr.Dr(ドラムトラック)は削除できませんので、不要のときは、[表示]メニューの[トラック]でチェックを外して非表示にしてください。
パートを追加する
パートを追加するには、[編集]メニューの[トラックの追加]を実行してください。
パートを追加したときはこちらの記事のように、[設定]メニューの[各トラックの設定]で、追加したパートのMIDI Ch.を他のパートで使っていない数値(「8」など)に変更してください。
楽譜のレイアウトを調整する
パートの非表示、削除、追加のいずれかを実行したら、下図(クリックすると拡大します)のように、[設定]メニューの[楽譜のレイアウト]ダイアログボックスにある[1ページの段数]で、1ページ内に表示する五線の段数を調整してください。
Line_count
Note Editor起動直後の[1ページの段数]には、初期設定の8パート構成に合わせて「8」が設定されています。これは、1ページ内に五線が8段分表示されるということです。
下図左は、初期設定の8パート構成からTr.7を非表示にして7パート構成にしただけで、[1ページの段数]を変更しなかったもの。下図右は、7パート構成にしたあと[1ページの段数]を「7」に変更したものです。
Tr7_line8_7
下図は、[1ページの段数]を「14」にして、7パートを1セットとして、ページ内に上下2セット表示させています。
Tr7_line14
先ほどの[1ページの段数]を「7」に設定した楽譜は、1ページに4小節分(1~4小節)が表示されていましたが、この「14」を設定した楽譜は、1ページに8小節分(上半分に1~4小節、下半分に5~9小節)表示されています。
実際に設定するときは、見やすい方を選べばいいと思います。
下図左の2枚は、初期設定の8パート構成から1トラック分追加して9パート構成しただけで、[1ページの段数]を変更しなかったもの。下図右は、9パート構成にしたあと[1ページの段数]を「9」に変更したものです。
Tr9_line8_9
図左を見ると、9パート目のTr.Drが、1ページ目に収まりきれずに2ページ目に表示されています。
このように、[1ページの段数]を調整しないと、パート構成によっては見づらい楽譜になってしまいますのでご注意ください。
* 楽譜はすべて、Note Editorで保存したファイルをScore Magazineで開いたものです。

挿入する画像の基本的な編集方法2

前回楽譜に挿入した写真やイラストを、どのように編集したり入手したりするかを考えてみたいと思います。
写真を丸く切り取る
楽譜に挿入する写真は、お手持ちのものをそのまま使ってもいいと思いますが、少し手を加えて、前回のように丸く切り取っても面白いのではないでしょうか。
今回は、JTrimというソフトウェアを利用させていただきました。
作者様のページよりソフトをダウンロード(*)して、パソコンにインストールし、ソフトを起動してみてください。
* 上記リンクページの左メニューよりJTrimのページに行き、ページ中央までスクロールすると「セットアップ版 JTrim Version 1.53c」があります。このファイルをダウンロードしてダブルクリックするとインストールが始まります。
まず、[ファイル]メニューの[開く]で丸く切り取りたい写真を開きますが、デジカメで撮った写真そのままでは大きすぎて編集しづらいと思いますので、下図(クリックすると拡大します)のように[表示]メニューの[ズーム]で「25%」などに見た目を小さくします。
Jtrim1
[イメージ]メニューの[切り抜き]をクリックすると、下図のような画面になります。
Jtrim2
四角い枠の部分が切り取られる範囲で、その枠四隅の赤丸部分をドラッグすると、その範囲のサイズを変更できます。
四角い枠内部をクリックしたままドラッグすると、範囲を移動させることができます。
もし、四角い枠が消えてしまったら、写真上をマウスでドラッグすれば再表示されます。
[OK]ボタンをクリックすると切り取られます。
次に、[イメージ]メニューの[円形切り抜き]をクリックして、表示されたダイアログボックスの[OK]ボタンをクリックしてください。丸く切り取られます。
最後に、[表示]メニューの[ズーム]で見た目を原寸サイズに戻し(最初の図を参照)、[イメージ]メニューの[リサイズ]で楽譜に表示したいサイズに変更して保存してください。
Jtrim3
前回の楽譜の写真は、横150×縦150ピクセルにしています。
イラストを作成、または入手する
前々回で、Windowsのペイントで簡単な図形を作成しましたが、慣れればペイントでもかなり本格的なイラストを描けるようです。
Googleで「Windows ペイント 使い方」や「windows ペイント イラスト」などと検索すると、ペイントの詳しい使い方や、イラストの描き方を解説するページにヒットします。
「自分で描くのはちょっと・・・」という方は、素材集のイラストを利用されるといいと思います。
素材集は書店などでも購入できますし、Googleで「素材」や「素材 イラスト」などと検索すれば商品にヒットすると思います。